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Introduction to ParaView

= What is ParaView
= The ParaView Architecture

= Hands-on: Basic Usage of ParaView
= Getting Data
= Interacting with 3D View
= Representation and Field Coloring
= Filter and Pipeline
= Commonly used filters
= contour, slice, clip, streamline, tube, glyph
= Vector Visualization
= Streamline, tube, glyph
= Multiview

= Volume Rendering

T

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu




What 1s ParaView

= An open source visualization
software for 2D/3D data sets

= Started in 2000 as a collaborative
effort between Kitware Inc and Los
Alamos National Labratories

= Supports multi-platforms: Windows,
Linux, MacOS

= Supports distributed computation for
large data sets

= Has an open, flexible, and intuitive
user interface

= Has an extensible and modular
architecture based on open standard

= Free for non-commercial use

T
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Focus of this
short course

ParaView Architecture

ParaView Client | pvpython | ParaWeb | Catalyst [ Custom App
N |
Ul (Qt Widgets, Python Wrappings)
ParaView Server
VTK
OpenGL MPI lceT Etc.
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Why Visualization

= A picture is worth a thousand words.

[pinglucfadat datal$ xxd disk out ref.ex2 |more
0000000: 4344 4501 0000 0001 0000 000a 0000 0019 Properties Information
0000010: 0000 000a 6ce5 e=Sf 7374 7269 geed 0000

AngularVelocity

Information I

0000020: 0000 0021 0000 0008 6cC6E5 6eSf 6Cc69 EeES barlaiy
0000030: 0000 0051 0000 0004 666f 7572 0000 0004 e

0000040: 0000 0009 7469 6d65 S5f73 7465 7000 0000 Type:  Multi-block Dataset

0000050: 0000 0000 0000 0007 6e75 6d5Ef 6469 6400 Number of Celle: 747

0000060: 0000 0003 0000 0009 6e75 6dSEf 6e6f 6465

0000070: 7300 0000 0000 2133 0000 0008 6e75 6dSE LTI I e

0000080: 656c 656d 0000 1d30 0000 000a 6e75 6dSE Memory: 2 MB

0000090: 656c 5f62 6céb 0000 0000 0001 0000 000d
00000a0: 6275 6d5f 6e6f 6465 S5f73 6574 7300 0000 ST LT ! 047585
00000b0: 0000 0003 0000 000d 6e75 6dSf 7369 6465 Current data time: 0

00000c0: 5£73 6574 7300 0000 0000 0007 0000 000a Name DataType Data Ranges ~

00000d0: 6275 6d5f 7161 S5£72 6563 0000 0000 0003

00000e0: 0000 0008 6e75 6dSf 696e 666f 0000 000a ° AsH3 double  [0.0804768, 0.184839]

00000£0: 0000 000e 6275 6dSf 656c SEE9 6e5f 626c ° CH4 double  [0,0.00117024]

0000100: 6b31 0000 0000 1d30 0000 000f 6e75 6dSf e GaMe3 double  [0.000222844, 0.007213...

0000110: é=6f 645f 7065 725f 656c 3100 0000 0008 ¢ GlobalNodeld idtype (1, 8499]

0000120: 0000 000b 6275 6dSf 6e6f 645f 6e73 3100 o H2 double  [0.807613, 0.917688]

0000130: 0000 0001 0000 000b 6e75 6dSf 6e6f 645f o PedigreeNodeld idtype [1, 8499]

0000140: 6e73 3200 0000 0001 0000 000b 6e75 6dSfE o Pres double  [0.00678552, 0.0288185]

0000150: eée6ef ©45f 6=73 3300 0000 0001 0000 000c e Temp double [293.15 913.15]

0000160: 6275 6d5f 7369 6465 S5£73 7331 0000 0lal oV double  [-19.9491 19.9491]. [-1..

0000170: 0000 000c 6275 6d5f 7369 6465 5f73 7332 @ GlobalElementld  idtype 74721 9

0000180: 0000 006c 0000 000c 6e75 6dSEf 7369 6465

0000190: 5£73 7333 0000 033c 0000 000c 6e75 6dSf Bounds

00001a0: 7369 6465 5f73 7334 0000 0048 0000 000c X range: -5.75 to 5.75 (delta: 11.5)

00001b0: 6e75 6d5f 7369 6465 5£73 7335 0000 00b4 Y range: -5.75 to 5.75 (delta: 11.5)
00001c0: 0000 000c 6e75 6d5f 7369 6465 5£73 7336 Z range: -10 to 10.2 (delta: 20.2)
00001d0: 0000 03c4 0000 000c 6e75 6d5f 7369 6465

T
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ParaView User Interface

Menu bar —— File Edit View Sources Filiers Tools Catalyst Macros Help

R B2 » ?F D KA>DIE Tme B
Toolbars 4 [ . ¢ ‘e F) =) (Repmsenmton o) BB 3 BB QAL - [B)
_ Pipeline Browser BX | OLayout#t x | 4 |
B builtin: EAELEE LT L L L L RenderViewl (@8]0 & | x|
Pipeline B
browser
Properties l Infarmation |
P ro p e rty > Properties &) x|
pan6| Apply || Reset | Delete |
Il |35
Advanced : | - ‘ ‘;l
= Properties ‘ W' | 0 ‘ N, | al |—|
toggle Ep——
Disply 3oL
) = View (Render View) ‘ [:D |r o ‘ _g i_ﬂ_i
3D view Axes Grid Edit |
Center Axes Visibility ﬂ
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Getting Data

= Creating a source from the menu Sources
= | oading from a file
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Interacting with a 3D View

= Create a Source: Sources -> Cylinder
= Change parameters: resolution -> 80

= Play with camera controls Al W N s IS

= Play with center access
controls

I I R |

o~ (& &

T
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Loading from a File

= ParaView provides different readers to read

in: /
¢ Examples
ome

different types of input files.

= File -> Open -> Examples ->
disk_out_ref.ex2

= To view the file, click the eye next to
disk _out_ref.ex2 in the pipeline browser.

Scroll down to see

9 data
9 run

O © 0 R

I -

Filename
i bin
= boot
B cgroup
9 dev
E etc
9 general
B gpfs
= home
5 lib
9 libs4
= media
E mnt
9 opt
9 proc
9 root
9 sbin

File name: |

Cancel

Files of type: SupportedFles( .inp *.cosmo *.cgns *.cml *.csv*.txt*.CSV". ‘v
s " Q - . - Al

ADAPT Flles( nc *cdf *elev”® ncd )
AMR Enzo Files(*.boundary *.hierarchy )
AMR Flash Files(*.Flash * flash )

ANSYS Files(*.inp )

UXFile Files(*.aux )

a list of supported
file types

T
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AVS UCD Binary/ASCII Files(".inp )

Adaptive cosmo files(*.cosmo )

BOV Files(*.bov ) a
BYU Files(*.g) oA




Representation and Active Variable Controls

Toggle Reset Scalar
color scalar range to Vector
legend range visible component
E 3 )i C @ °V v Magnituc ¥ = Surface i
Edit color Custom Mapped representation
scalar variable
range

T
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Representation

RenderViewl [|H O & x & a0 B - ] 2 rRenderViews M A/O[&][x

Tarmp Temp
— 21322402 — 21322402

738,15 75815

. Surface

RenderViewd @D B O & |x &

'.ﬂgkadcrs

1
2

3

-

b_m

a8

Outline Wireframe 52

10
ne"
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Change Color Map

= Edit Color Map ->

Color Map Editor 8 X
]
Array Name: Temp

[] Lock Data Range ~
|:| Interpret Values As Categories
[] Rescale on visibility Change

Search ... (use Esc to clear text)

Mapping Data

> o

Data:
[] use log scale when mapping data te colors

[] Enable opacity mapping for surfaces

Color transfer function values

Value R G B
1 293.15 0231373 0298039 0.752941
2 680315 0.865 0.865 0.865

3 91315 0705882 0.0156863 0.14902

Opacity transfer function values

Value Opacity
1 293.15 0
2 913.15 1

Color Mapping Parameters

Color Space Diverging - | w

T

Texas A&M University

Choose Preset |iw | -> Black Body Radiation -> Apply

Il Choose Preset ? >

|| Options to load:

Presets ~ |1 Colors
Opacities
- - Cool to Warm ’
Use preset range
B I C ool to Warm (Extended)
- - Warm to Cool

B B /2 to Cool (Extended)
- - - Rainbow Desaturated
BN coid and Hot

Black-Body RadiatiD
T < Ry

_ Grayscale
[ Black, Blue and White
B Black, Orange and White Apply
B | inear YGE 1211g TP
_ Linear Green (Gr4L) Export
_ Linear Blue (8_31f) Remaove
- . Blue to Red Rainbow v Close

Tip: <click> to select, <double-click>> to apply a preset.
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Color Map Editor 8 X

&[]

[ ] Lock Data Range "~

Search ... (use Esc to clear text)

Array Name: Temp

D Interpret Values As Categories
[ ] Rescale On Visibility Change

Mapping Data

Data:
[ ] use log scale when mapping data to colors

] Enable opacity mapping for surfaces

Color transfer function values

Value R G B
1 293.15 0 0 0
2 54115 0.901961 0O 0
3 789.15 0.901961 0901961 0O
4 91315 1 1 1

Opacity transfer function values

Value Opacity
1 293.15 0

2 91315 1 v



Filter and Pipeline

= Filter: a functional unit that " Visualization Pipeline

processes the data to
generate, extract, or derive .

features from the data.

‘Source
Y

_— Y

YooYy
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Commonly Used Filters

Extract Stream Group
contour slice subnet tracer datasets

T T T 1
% E; st -_ {:%? ;EE - *'3}
| | | | |

calculator cllp threshold glyph warp Extract
level

T
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Slice

= Make sure disk_out_ref.ex2 is
loaded

= Click “slice” -> uncheck “show plane”
In Plane Parameters -> Apply

= Change active variable to “temp”

=9.132e+02

= Set view direction to +X

= Rotate the slice to view from different o
angles | =

=2931=+02

T
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Contour

" Edit -> Reset Session

= | oad disk_out ref.ex2 ->
check all variables -> apply

= Active variable -> pres
= Representation -> Wireframe

= Contour -> In Properties tab
click “temp” for “Contour by”

= Change “Isosurfaces” value to T
11 » NI T L) i It T A
400” -> apply =

0011016

6.786e-03

T
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Extract Surface

= Continue from previous slide
= Representation -> Surface

= Filters -> Alphabetical ->
Extract Surface -> apply

= Select “ExtractSurfacel” ->
Clip -> uncheck “show plane”
In “Plane Properties” -> Apply

Pipeline Browser Visualization Pipeline

0016525

@ buitin: Disk_out_ref.ex2

@ Qlj disk_out_ref.ex2 ,
@ ®© contourt /\ ' e 0011016
@ W Earacsurface! Contourl  ExtractSurfacel 6.7862-03
- ©Em l

Clipl
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Save/Load State

B e -> Save State
" File -> Load State

Pipeline Browser g X
ﬁ builtin:

b !f‘] disk_out_ref.ex2

& © contourl

@ © bdractSurfacel

> ©gm

0.016525

=-0011016

6.786e-03

T
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Vector Visualization - Streamlines

= The data set has a velocity field
describing the movement of the
alr over the heated rotating disk.

= The filter Stream Tracer can be
used to determine the currents
In the air.

= Click & Stream Tracer from
common filters -> Apply

T
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Enhanced Streamlines

= Stream Tracer draws 1d 5 e s
lines that has no thickness. s.-cam o " wn Giiiuies vooa

= No shading | =
= No direction
= Can be enhanced with

Properties

other filters S —
H Ctr|+SpaCe (qUiCk ‘...\, ‘. > l\ \ 3 ;Y: ;940%e+02

~766.87

search) -> Tube ->Apply == . D
Orientation z -~
" Glyph -> Apply .
Glyph Properties: ::;w i [oossoirescsed ] ) =3.387e+02

Glyph Source: Glyph Type = cone
Active Attributes: Vectors =V
Scaling: Scale Mode = vector
Scale Factor = 0.5904.. (click € to set the value)

T
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Multiview

= On top right of ‘view’, there are buttons for splitting, resizing,
and deleting views.

T
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Using Multiview

ORI PE BB R AN » Renderviewl @/ B O& X & 30 @ W OEE KN ®EEE R A » RenderView2 [@||B|0O) &)X

" Edit -> Reset Session

= Fjle -> Recent File ->
disk_out_ref.ex2

= Clip -> color by Pres
= Split Vertically

= Click the right view

= Clip -> color by Temp

T
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Linking Camera

= Right click one view
= Select “Linking Camera”
= Click the other view

= The two views are now
using the same camera —
rotating one view causes
the other view to rotate In
the same direction. Very
convenient for viewing the
value of different variables
at the same |ocation.

00178

0.01229

T
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Volume Rendering

= Asolid mesh is rendered as a
translucent cloud, with the scalar field
determining the color and density at
every point in the cloud.

= The benefit Is to see features all the
way through a volume

= Filters -> Data Analysis -> Histogram ->
Apply

Temp
—9.132e+02

758.15

603.15

448,15

—2931e+02

T
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Exercise 1

= Do volume rendering in Multiview with temperature
and pressure respectively.

T
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Exercise 2

= Start with a new session.

= Add a streamline augmented with tube and glyph to
the volume rendering with temperature.

= Change the transfer function to “Black-Body
Radiation”.

T
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Further Reading

= ParaView tutorial

https://www.paraview.org/Wiki/The_ParaView_Tutorial

= ParaView user guide

https://www.paraview.org/paraview-guide/

= Sandia National Lab ParaView tutorials

https://www.paraview.org/Wiki/SNL_ParaView_4 Tutorials

T
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