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= Introduction to TAMU Visualization Portal

= Using the porta

= Introduction to ParaView
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The TAMU Visualization Portal

=\What Is I1t?

*"\Who can use It?

" \What's the benefit of using it?

"|s It free?

=" \What applications can be used with it?

T

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu




The TAMU Visualization Portal

= A web service for submitting and viewing remote visualization
jobs

= Ada users with our permission

= [t supports major web browsers (lIE, Firefox, Chrome) and can
be accessed anywhere with Internet connection (VPN Is
needed from off-campus connections)

= |t Is free, but Ada allocations are charged

= Any GUI applications that support OpenGL can use the portal,
iIncluding ABAQUS, ANSYS, COMSOL, Paraview, Matlab GUI,
etc.

T
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T

Workflow of the Portal

https://ada7.tamu.edu/vis-portal

cee

1. Submission request

7. Cqmnect to vncserver

End user
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3. The job runs on a

visualization compute node with GPU

4. The job starts a

gateway 2. vncjob.submit
=By 1VNC serverand a
e websockify proxy

A
“7‘. ) m
g dserver

6. Set up port forwarding s
to the proxy port s

2. Gateway , ’
obtains the proxy j#¥e
port number e

Ada cluster




Accessing the Visualization Portal

= Please request permission to access https://ada7.tamu.edu/vis-portal
the portal by sending an email to
help@hprc.tamu .EdU High Performance Research Computing m EXAS

A Resource for Research and Discovery o S LT Y.

= |f you are off-campus, please first o
] Welcome to the Ada Remote Visualization Portal
|Og I n to th e TAM U V P N The visualization portal is access-restricted. Please contact us at helpdesk@hprc.tamu.edu to request access to the portal.

Please login with your TAMU NetID and password.

= Using a web-browser open
https://ada’.tamu.edu/vis-portal/

= Please confirm the security exception
to access the site

= Use your TAMU Net-ID and password
to log into the portal. Enter your TAMU Net-1D

T
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mailto:help@hprc.tamu.edu

For New Remote Visualization Users

High Performance Research Computing

A Resource for Research and Discovery

0= Jobs  Help
You are logged in as pingluo, [logout Friday, September 29, 2017

* You must set your VNC password at least once. Click "password” to set your VNC
password.

Password | Set your VNC password

Ada Remote Visualization Portal help@hprc.tamu.edu

T
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Setting Your VNC Password

High Performance Research Computing m TEXAS A&M

A Resource for Research and Discovery UNTVERS LY.

3088 Jobs  Help
You are logged in as pingluo, [logout Friday, September 29, 2017

Your VNC password MUST NOT be the same as your netid password.
Your VNC password must have at least 6 characters.
Password:
Re-type Password:

OK

Ada Remote Visualization Portal help@hprc.tamu.edu
AJm
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Submitting a Visualization Job

High Performance Research Computing ’T” ‘ TEXAS A&M

A Resource for Research and Discovery UNTVERSTTY.

=88 Jobs  Help
You are logged in as pingluo, [logout Friday, September 29, 2017

Customize your job specifications in the form below.

Select a preset remote desktop resolution closest to your desktop resolution.
Email is needed only if you want to be informed when your job starts running.
Job specifications cannot be changed after the job is submitted.

Remote desktop resolution: width x height 1024x768 v
Number of CPU cores: 1
Memory size (between 2 to 250): 8 GB
Email (optional):
Submit Submit a visualization job.

e Your VNC password has been set. If you want to change it, click "password.”

Password #Change your VNC password
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Submitting a Visualization Job

High Performance Research Computing m ‘ TF‘?K\AISR{‘?M

A Resource for Research and Discovery

i pingluo, [logout!

e Customize your job specifications in the form below.

e Select a preset remote desktop resolution closest to your desktop resolution.

*  Email is needed only if you want to be informed when your job starts running.

* Job specifications cannot be changed after the job is submitted.
o — — -

Remote desktop resolution: width x height

Number of CPU cores: 4

Memory size (between 2 to 250): 8

Email (optional )}

Submit Submit a visualization job.

304
o [|nge it, click "password.”

T
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Remote desktop resolution: width x height | 1024x768

_ 1024x768
Number of CPU cores: 4 1280x960

Memory size (between 2 to 250): 8 GB | 1280x1024
1600x1024
1920x1080
2048x1280
: _ _ L 2560x1440
Submit Submit a visualization job. 1900x1800

3840x2160

4096x2304
Your VNC password has been set. If you  4500x3000

Email (optional):




Submitting a Visualization Job

ada7.tamu.edu says:

High Performanc ‘ TEXAS A&M

A Resource for Research You Job has been submitted. UNIVERSITY.

Jobs  Help
You are logged in as pingluo, [logout Friday, September 29, 2017

Customize your job specifications in the form below.

Select a preset remote desktop resolution closest to your desktop resolMO u r u S ag e WI I I

Email is needed only if you want to be informed when your job starts ruBirlg.

Job specifications cannot be changed after the job is submitted. e C h arg ed l

Remote desktop resolution: width x height 1024x768 ~
Number of CPU cores: 1

Memory size (between 2 to 250): 8 GB

Email (optional):

Submit Submit a visualization job.

T

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu




— The Job Control Page

You are logged in as pingluo, [logout
* When your job starts running, click View to connect to the VNC server. You will be
redirected to a different page.
e Type your VNC password to login into the remote desktop.

e The GUI application must be launched with vglrun to use hardware acceleration.
* To go back to the main page, first toggle up the control bar at the leftmost center of

U
your screen, and then click the disconnect button .
e Delete your job by clicking Delete when you are done with your visualization job.

Refresh | Your job 6238264 is running.

dnnect to the VNC server and start running GUI applications.

Delete Delete the visualization job.

e Your VNC password has been set. If you want to change it, click "password.”

Password | Change your VNC password

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu
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Connecting to the VNC Server

/ Your connection Is not secure

The owner of ada/.tamu.edu has configured their website improperly. To protect your information from being stolen,
Firefox has not connected to this website.

Learn maore...

Report errors like this to help Mozilla identify and block malicious sites

ada/.tamu.edu:10056 uses an invalid security certificate.

The certijcate iz not '[r'u.S’[E_FI:J because it is EEI:—signEd. Ad d eX C e p t i O n
__— and accept the
certificate

Error code: SEC_ERROR_UNKNOWN_ISSUE

Add Exception...

m‘l Texas A&M University  High Performance Research Computing

— http://hprc.tamu.edu



Connecting to the VNC Server

.
This is your VNC  [’%

password,
and not your TAMU
NetID password
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The Remote Desktop

« » Applications Places System Q S

-

Computer

oA 2003 -~ rvee )33 )
iDUun4d—-3UV1L D gilUuol g

pingluo’s Hom

m‘l Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu



T

Disconnecting From the VNC Server

w« » Applications Place

Home

Jobs  Help
You are logged in as pingluo, [logout

Friday, September 29, 2017

H
@ * When your job starts running, click View to connect to the VNC server. You will be
_‘-_t' = redirected to a different page.
Computer
Sl Filg ¢ Type your VNC password to login into the remote desktop.
[ ¢ The GUI application must be launched with vglrun to use hardware acceleration.
* To go back to the main page, first toggle up the control bar at the leftmost center of
)
e your screen, and then click the disconnect button .
ningluo’s Hom
Ping : ¢ Delete your job by clicking Delete when you are done with your visualization job. [
Refresh | Your job 6238264 is running.
View Connect to the VNC server and start running GUI applications.
Delete Delete the visualization job.
* Your VNC password has been set. If you want to change it, click "password.”
Password | Change your VNC password
H

Disconnect

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu

Disconnecting
returns the user to
the job control page

The job continues to
run and can be
accessed by clicking
“view” on the job
control page.

Charging continues
till the job Is deleted
from the Job Control

page



Deleting a Visualization Job

ada7.tamu.edu says:

Deleting a job
terminates it

High Performance

You job 6238264 has been deleted.

A Resource for Research i

permanently
Jobs  Help
You are logged in as pingluo, [logout Friday, September 29, 2017 .
Charging stops at
¢« When your job starts running, click View to connect to the VNC server. You will be th|S p0|nt
redirected to a different page.
e Type your VNC password to login into the remote desktop. "
ype your VI- P ’ | P | = You will be brought
e The GUI application must be launched with vglrun to use hardware acceleration.
e To go back to the main page, first toggle up the control bar at the leftmost center of baCk to the JOb
)
your screen, an_d then cl_ick. the disconnect button . | | - SumeSSIOn page
* Delete your job by clicking Delete when you are done with your visualization job.
= . .
Refresh  Your job 6238264 is running. TO SmeIt a neW JOb
please repeat
View Connect to the VNC server and start running GUI applications. .
previous the steps
te the visualization job.

T
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How Are SUs Charged

= Equivalent CPU cores based on memory request:

0-2.56G 1 core
2.56G—-5.12G 2 cores

5.12G - 7.68G 3 cores

= SUs are charged based on actual wall-time times the
maximum of actual CPU cores and equivalent CPU cores
1SU=1corex1 hour

SUcharged = Max{num_cores, equiv_cores} x wall-time
= Maximum wall-time is 6 hours (remote visualization is for pre-

and/or post-processing, and short analyzing).

T

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu




Getting Help!

High Performance Research Computing m ‘ TEXAS A&M

A Resource for Research and Discovery vNTVERSTEY.

Home Jobs ﬁ

You are logged in aspmagluo, [logout Friday, September 29, 2017

Getting Started

FAQ (under construction)

Ada Remote Visualization Portal help@hprc.tamu.edu

=https://hprc.tamu.edu/wiki/Ada:Remote-Viz#Alternative Method: Visualization Portal
"helpdesk@hprc.tamu.edu

T
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Launching Applications

« » Applications Places System Q S

-

Computer _ : :
File Edit View Search Terminal Help

Y T -~ > R e~
T Luoldgpund—-s0U0Ul pLngiuole

pingluo’s Hom

“vglrun” is used to
launch applications
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Launching ParaView

pingluo@gpub4-3002:/general/home/pingluo

File Edit View Search Terminal Help

[pingluo@gpu64-3002 pingluo]$ module load ParaView/5.1.2
[pingluo@gpu64-3002 pingluco]$ vglrun paraview

vglrun paraview

T

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu




Launching ParaView

r
/] ParaView 5.1.2 64-bit

File Edit View Sources Filters Tools Catalyst Macros Help

= e
Sl -
B g ¢ 2 _4;’ });' @ » &1 »
Pipaline Bf
B builtin:
| . Sandia
Properties 1 Information | ))K Kltware m&m
Proper
Apy Rese c) \
R ‘LosAlamos S A AKL

| == Properties

=10y Getting Started Guide Example Visualizations
= View (Render View)
' | | Don't show this window again -x Close
Axes Grid 9
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Introduction to ParaView

= What is ParaView

= The ParaView Architecture

= Hands-on: Basic Usage of ParaView
= Getting Data
= Interacting with 3D View
= Representation and Field Coloring
= Filter and Pipeline
= Commonly used filters
= contour, slice, clip, streamline, tube, glyph
= Vector Visualization
= Streamline, tube, glyph
= Multiview
= Plotting

.
/ A ) 4
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What 1s ParaView

= An open source visualization
software for 2D/3D data sets

= Started in 2000 as a collaborative
effort between Kitware Inc and Los
Alamos National Labratories

= Supports multi-platforms: Windows,
Linux, MacOS

= Supports distributed computation for
large data sets

= With an open, flexible, and intuitive
user interface

= Has an extensible and modular
architecture based on open standard

= Free for non-commercial usage

T
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AJm

Focus of this
short course

ParaView Architecture

ParaView Client | pvpython | ParaWeb | Catalyst [ Custom App
N |
Ul (Qt Widgets, Python Wrappings)
ParaView Server
VTK
OpenGL MPI lceT Etc.
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Why Visualization

= A picture is worth a thousand words.

[pinglucfadat datal$ xxd disk out ref.ex2 |more
0000000: 4344 4501 0000 0001 0000 000a 0000 0019 Properties Information
0000010: 0000 000a 6ce5 e=Sf 7374 7269 geed 0000

AngularVelocity

Information I

0000020: 0000 0021 0000 0008 6cC6E5 6eSf 6Cc69 EeES barlaiy
0000030: 0000 0051 0000 0004 666f 7572 0000 0004 e

0000040: 0000 0009 7469 6d65 S5f73 7465 7000 0000 Type:  Multi-block Dataset

0000050: 0000 0000 0000 0007 6e75 6d5Ef 6469 6400 Number of Celle: 747

0000060: 0000 0003 0000 0009 6e75 6dSEf 6e6f 6465

0000070: 7300 0000 0000 2133 0000 0008 6e75 6dSE LTI I e

0000080: 656c 656d 0000 1d30 0000 000a 6e75 6dSE Memory: 2 MB

0000090: 656c 5f62 6céb 0000 0000 0001 0000 000d
00000a0: 6275 6d5f 6e6f 6465 S5f73 6574 7300 0000 ST LT ! 047585
00000b0: 0000 0003 0000 000d 6e75 6dSf 7369 6465 Current data time: 0

00000c0: 5£73 6574 7300 0000 0000 0007 0000 000a Name DataType Data Ranges ~

00000d0: 6275 6d5f 7161 S5£72 6563 0000 0000 0003

00000e0: 0000 0008 6e75 6dSf 696e 666f 0000 000a ° AsH3 double  [0.0804768, 0.184839]

00000£0: 0000 000e 6275 6dSf 656c SEE9 6e5f 626c ° CH4 double  [0,0.00117024]

0000100: 6b31 0000 0000 1d30 0000 000f 6e75 6dSf e GaMe3 double  [0.000222844, 0.007213...

0000110: é=6f 645f 7065 725f 656c 3100 0000 0008 ¢ GlobalNodeld idtype (1, 8499]

0000120: 0000 000b 6275 6dSf 6e6f 645f 6e73 3100 o H2 double  [0.807613, 0.917688]

0000130: 0000 0001 0000 000b 6e75 6dSf 6e6f 645f o PedigreeNodeld idtype [1, 8499]

0000140: 6e73 3200 0000 0001 0000 000b 6e75 6dSfE o Pres double  [0.00678552, 0.0288185]

0000150: eée6ef ©45f 6=73 3300 0000 0001 0000 000c e Temp double [293.15 913.15]

0000160: 6275 6d5f 7369 6465 S5£73 7331 0000 0lal oV double  [-19.9491 19.9491]. [-1..

0000170: 0000 000c 6275 6d5f 7369 6465 5f73 7332 @ GlobalElementld  idtype 74721 9

0000180: 0000 006c 0000 000c 6e75 6dSEf 7369 6465

0000190: 5£73 7333 0000 033c 0000 000c 6e75 6dSf Bounds

00001a0: 7369 6465 5f73 7334 0000 0048 0000 000c X range: -5.75 to 5.75 (delta: 11.5)

00001b0: 6e75 6d5f 7369 6465 5£73 7335 0000 00b4 Y range: -5.75 to 5.75 (delta: 11.5)
00001c0: 0000 000c 6e75 6d5f 7369 6465 5£73 7336 Z range: -10 to 10.2 (delta: 20.2)
00001d0: 0000 03c4 0000 000c 6e75 6d5f 7369 6465

T
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ParaView User Interface

Menu bar —— File Edit View Sources Filiers Tools Catalyst Macros Help

R B2 » ?F D KA>DIE Tme B
Toolbars 4 [ . ¢ ‘e F) =) (Repmsenmton o) BB 3 BB QAL - [B)
_ Pipeline Browser BX | OLayout#t x | 4 |
B builtin: EAELEE LT L L L L RenderViewl (@8]0 & | x|
Pipeline B
browser
Properties l Infarmation |
P ro p e rty > Properties &) x|
pan6| Apply || Reset | Delete |
Il |35
Advanced : | - ‘ ‘;l
= Properties ‘ W' | 0 ‘ N, | al |—|
toggle Ep——
Disply 3oL
) = View (Render View) ‘ [:D |r o ‘ _g i_ﬂ_i
3D view Axes Grid Edit |
Center Axes Visibility ﬂ
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Getting Data

= Creating a source from the menu Sources
= | oading from a file
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Interacting with a 3D View

= Create a Source: Sources -> Cylinder
= Change parameters: resolution -> 80

= Play with camera controls Al W N s IS

= Play with center access
controls

I I R |

o~ (& &

T
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Loading from a File

= ParaView provides different readers to read

in: /
¢ Examples
ome

different types of input files.

= File -> Open -> Examples ->
disk_out_ref.ex2

= To view the file, click the eye next to
disk _out_ref.ex2 in the pipeline browser.

Scroll down to see

9 data
9 run

O © 0 R

I -

Filename
i bin
= boot
B cgroup
9 dev
E etc
9 general
B gpfs
= home
5 lib
9 libs4
= media
E mnt
9 opt
9 proc
9 root
9 sbin

File name: |

Cancel

Files of type: SupportedFles( .inp *.cosmo *.cgns *.cml *.csv*.txt*.CSV". ‘v
s " Q - . - Al

ADAPT Flles( nc *cdf *elev”® ncd )
AMR Enzo Files(*.boundary *.hierarchy )
AMR Flash Files(*.Flash * flash )

ANSYS Files(*.inp )

UXFile Files(*.aux )

a list of supported
file types

T
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AVS UCD Binary/ASCII Files(".inp )

Adaptive cosmo files(*.cosmo )

BOV Files(*.bov ) a
BYU Files(*.g) oA




Representation and Active Variable Controls

Toggle Reset Scalar
color scalar range to Vector
legend range visible component
E 3 )i C @ °V v Magnituc ¥ = Surface i
Edit color Custom Mapped representation
scalar variable
range

T
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Representation

RenderViewl [|H O & x & a0 B - ] 2 rRenderViews M A/O[&][x

Tarmp Temp
— 21322402 — 21322402

738,15 75815

. Surface

RenderViewd @D B O & |x &

'.ﬂgkadcrs

1
2

3

-

b_m

a8

Outline Wireframe 52

10
ne"
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Change Color Map

= Edit Color Map ->

Color Map Editor 8 X
]
Array Name: Temp

[] Lock Data Range ~
|:| Interpret Values As Categories
[] Rescale on visibility Change

Search ... (use Esc to clear text)

Mapping Data

> o

Data:
[] use log scale when mapping data te colors

[] Enable opacity mapping for surfaces

Color transfer function values

Value R G B
1 293.15 0231373 0298039 0.752941
2 680315 0.865 0.865 0.865

3 91315 0705882 0.0156863 0.14902

Opacity transfer function values

Value Opacity
1 293.15 0
2 913.15 1

Color Mapping Parameters

Color Space Diverging - | w

T

Texas A&M University

Choose Preset |iw | -> Black Body Radiation -> Apply

Il Choose Preset ? >

|| Options to load:

Presets ~ |1 Colors
Opacities
- - Cool to Warm ’
Use preset range
B I C ool to Warm (Extended)
- - Warm to Cool

B B /2 to Cool (Extended)
- - - Rainbow Desaturated
BN coid and Hot

Black-Body RadiatiD
T < Ry

_ Grayscale
[ Black, Blue and White
B Black, Orange and White Apply
B | inear YGE 1211g TP
_ Linear Green (Gr4L) Export
_ Linear Blue (8_31f) Remaove
- . Blue to Red Rainbow v Close

Tip: <click> to select, <double-click>> to apply a preset.

High Performance Research Computing — http://hprc.tamu.edu

Color Map Editor 8 X

&[]

[ ] Lock Data Range "~

Search ... (use Esc to clear text)

Array Name: Temp

D Interpret Values As Categories
[ ] Rescale On Visibility Change

Mapping Data

Data:
[ ] use log scale when mapping data to colors

] Enable opacity mapping for surfaces

Color transfer function values

Value R G B
1 293.15 0 0 0
2 54115 0.901961 0O 0
3 789.15 0.901961 0901961 0O
4 91315 1 1 1

Opacity transfer function values

Value Opacity
1 293.15 0

2 91315 1 v



Filter and Pipeline

= Filter: a functional unit that " Pipeline

processes the data to
generate, extract, or derive .

features from the data.

‘Source
Y

= W

YooYy
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Commonly Used Filters

Extract Stream Group
contour slice subnet tracer datasets

T T T 1
% E; st -_ {:%? ;EE - *'3}
| | | | |

calculator cllp threshold glyph warp Extract
level

T
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Slice

= Make sure disk_out_ref.ex2 is
loaded

= Click “slice” -> uncheck “show plane”
In Plane Parameters -> Apply

= Change active variable to “temp”

=9.132e+02

= Set view direction to +X

= Rotate the slice to view from different o
angles | =

=2931=+02

T
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Contour

" Edit -> Reset Session

= | oad disk_out ref.ex2 ->
check all variables -> apply

= Active variable -> pres
= Representation -> Wireframe

= Contour -> In Properties tab
click “temp” for “Contour by”

= Change “Isosurfaces” value to T
11 » NI T L) i It T A
400” -> apply =

0011016

6.786e-03

T
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Extract Surface

= Continue from previous slide
= Representation -> Surface

= Filters -> Alphabetical ->
Extract Surface -> apply

= Select “ExtractSurfacel” ->
Clip -> uncheck “show plane”
In “Plane Properties” -> Apply

Pipeline Browser

T 0016525
B builtin:

|
© disk_out_ref.ex2

= 0011016

!.‘3 Contourl
¥ extractSurfacel

oEm

o & 8 ©

6.786=-03

T
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Save/Load State

B e -> Save State
" File -> Load State

Pipeline Browser g X
ﬁ builtin:

b !f‘] disk_out_ref.ex2

& © contourl

@ © bdractSurfacel

> ©gm

0.016525

=-0011016

6.786e-03

T
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Vector Visualization - Streamlines

= The data set has a velocity field
describing the movement of the
alr over the heated rotating disk.

= The filter Stream Tracer can be
used to determine the currents
In the air.

= Click & Stream Tracer from
common filters -> Apply

T
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Enhanced Streamlines

= Stream Tracer draws 1d 5 e s
lines that has no thickness. s.-cam o " wn Giiiuies vooa

= No shading | =
= No direction
= Can be enhanced with

Properties

other filters S —
H Ctr|+SpaCe (qUiCk ‘...\, ‘. > l\ \ 3 ;Y: ;940%e+02

~766.87

search) -> Tube ->Apply == . D
Orientation z -~
" Glyph -> Apply .
Glyph Properties: ::;w i [oossoirescsed ] ) =3.387e+02

Glyph Source: Glyph Type = cone
Active Attributes: Vectors =V
Scaling: Scale Mode = vector
Scale Factor = 0.5904.. (click € to set the value)

T
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Multiview

= On top right of ‘view’, there are buttons for splitting, resizing,
and deleting views.

T
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Using Multiview

ORI PE BB R AN » Renderviewl @/ B O& X & 30 @ W OEE KN ®EEE R A » RenderView2 [@||B|0O) &)X

" Edit -> Reset Session

= Fjle -> Recent File ->
disk_out_ref.ex2

= Clip -> color by Pres
= Split Vertically

= Click the right view

= Clip -> color by Temp

T
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Linking Camera

= Right click one view
= Select “Linking Camera”
= Click the other view

= The two views are now
using the same camera —
rotating one view cause
the other view to rotate In
the same direction. Very
convenient for viewing the
value of different variables
at the same |ocation.

00178

0.01229

T

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu




Plot Over Line
= Plot Over Line & ->adjust both ends -> Apply

" |n“Series Parameters”, leave only “temp” and “pres” checked.

= Highlight “pres” -> select “Bottom-Right” for Chart Axes

Fipeline Browser & % O layout #1 X +
ﬁ builtin: ki WE HEH IR EE XA N?7R Renderviewl [M|[B|O][&®|x]| = = & 0 LineChartViewl @B O0//&|/x
1
© disk_out_refexz 950 - 00281
— Temp
L ] Clip1 —— Pres
> Lo pmm -
E L0.0261
850
00251
800
F0.0241
Properties Information 750 o023
Properties g x
700 10,0221
Apply Reset ¥ Delete ? =
- . = Lozt
|Search ... (use Esc to clear text) |Qg__: I 650
[] Points_M... . Paints_Mag... ~ |0.02
] Objectid [  Objectld 6001
L0019
[JH2 B -
[1Games [ GaMe3 550 ota
[ cH4 B cHs
[] AsH3 | ESE 500 Looi7
Line Thickness |2 = 250 roo1s!
Line Style Solid -
ty Loois:
Marker Style MNone - 400
Chart Axes Bottom-Right A Loaia
= View (Line Chart View) | o @ | a0
LOO13
Title
Chart Title |Use ${TIME} to display current time | 00 ! ! ! ! | | ! | | > 00121
n st LY 10 11 12 13 14 15 16 17 18 19 20 21
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Histogram

= Select “disk out ref.ex2” in the pipeline browser

T

= Filters -> Data Analysis -> Histogram -> Apply
Pipeline Browser & ¥ OLlayout #1 % +
lfl builtin: & @ | HEE Ep RSB R oA 7 @ Renderviewl [@|B|O|[&|x| & & & B O LineChartviewl @ |B| Q&%
1
) disk_out_ref.ex2 1000 00281
—_—Temp
o] Clip1 ——Pres
+0.026!
@ [+ PlotoverLine1 9004
@ 0™ Histogram!1 200 Lo.0z4
F0.0221
700
10.02
. 600
0.017802 LooT8
Properties Information 500
LO.01&1
Properties & X
0012294
400 4 L0014
Apply Reset 3 Delete ? =
|Search ... (use Esc to clear text) |Q§_‘, E ‘30010 N e 5 W 5 % e 18 % 20 2]rm]2|
— 6786203
| = Properties (Histogram1) | Do H o = = BarChartViewl |m|E|0]&|[%
Select Input Array | 5 acy3 o 2500
bir_values
Companent | 0 | 3000
| = Display (XYBarChartRepn | @ m 1@ H 2500
Attribute Type  Row Data -
o 2000 4
X Axis Parameters
[] use Index For XAxis 1500
X Array Name bin_extents -
Series Parameters 1000
~
[m]variable _egend Name
. . 500 4
bin_values . bin_values
[] bin_exte... . bin_extents
v 0.1 017 0.18 019
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Volume Rendering

= Asolid mesh is rendered as a
translucent cloud, with the scalar field
determining the color and density at
every point in the cloud.

= The benefit Is to see features all the
way through a volume

= Filters -> Data Analysis -> Histogram ->
Apply

Temp
—9.132e+02

758.15

603.15

448,15

—2931e+02
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Exercise 1

= Use Multiview to do volume rendering with
temperature and pressure respectively.

T
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Exercise 2

= Start with a new session.

= Add a streamline augmented with tube and glyph to
the volume rendering with temperature.

= Change the transfer function to “Black-Body
Radiation”.

T

Texas A&M University  High Performance Research Computing — http://hprc.tamu.edu




Further Reading

= ParaView tutorial

https://www.paraview.org/Wiki/The_ParaView_Tutorial

= ParaView user guide

https://www.paraview.org/paraview-guide/

= Sandia National Lab ParaView tutorials

https://www.paraview.org/Wiki/SNL_ParaView_4 Tutorials

T
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