
Workshop 2

Tosca – Topological Optimization

Introduction

This workshop will give you an opportunity to use Tosca optimization techniques from within the
Graphical User Interface (GUI) to reduce the weight of a Part. The results will be viewed in
Abaqus/CAE. You will take the approximate lug design analysed during Workshop 1 and then
use topological optimization to reduce the volume (weight) whilst maximizing the stiffness.

Preliminaries
Start a new session of Abaqus/CAE using the following command:

abaqus cae 
where abaqus is the command used to run Abaqus.

In the Start Session dialog box, underneath Create Model Database, click With 
Standard/Explicit Model.

To save the model database, select File→Save As from the main menu bar and type the file
name LugOpt in the Save Model Database As dialog box. Click OK.
The .cae extension is added to the file name automatically.

Creating a part
In this section you will import the .sat file of the lug you created during the Abaqus workshop, as 
a three-dimensional, deformable solid body.
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1. Abaqus/CAE automatically loads the Part module. Any other module can be accessed 
from the Module list located in the context bar.

2. From the main menu bar, select File > Import > Part to import a new part. Navigate to 
the directory where you saved file ‘lug.sat’ in workshop 1 and select the file. Click OK to 
import the file

3. In the Create Part from ACIS File window rename the part Part-1, accept all other 
defaults and click OK to import the part into the model.

At present the part is meshable using a sweep technique, however, you will partition the part in 
order to make it meshable with a uniform mesh which is more favourable for the Optimization 
task.

1. First you will create a partition which will split the single cell horizontally into 2 equal 
cells. From the menu bar select Tools > Partition and then Cell > Define cutting plane
in the create partition edit box

2. Select 3 points when asked how you want to specify the plane – then click the 3 points 
shown.
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3. Click Create partition to split the single cell part horizontally into 2 equal cells.
4. Then to add a second vertical partition through the hole centre, select Tools > Partition 

and then Cell > Define cutting plane in the create partition edit box
5. Select both cells of the lug to be partitioned – using shift-click or drag pick, then click 

done.
6. Select Normal to Edge as the means to specify the plane
7. Then select the top front edge of the lug and the point on the hole centerline

8. Click Create Partition and done to complete the action
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9. Finally you will add a second vertical partition offset by 75 mm from the fixed end of the 
lug. For this partition you will first create a datum plane to act as the partition plane – 
from the main menu select Tools > Datum > Plane and then Offset from plane.

10. Select one of the faces on the fixed end of the lug and Enter Value. You will be offsetting
the end plane towards the hole of the lug so you may need to flip the direction arrow. 
Once the arrow points towards the hole click OK and enter an offset value of 75 mm.

11. Now select Tools > Partition and then Cell > Use datum plane in the create partition 
edit box

12. Select both end cells of the lug to be partitioned – using shift-click or drag pick, then click
done.

13. Then select the datum plane you just defined. Click Create Partition and done to 
complete the partition.
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Save the Abaqus/CAE database.

Creating a material definition
You will now create a single linear elastic material with a Young’s modulus of 200103 MPa and 
Poisson’s ratio of 0.3.

To define a material:
1. In the Model Tree, double-click Materials to create a new material in the model Model-1.

Abaqus/CAE switches to the Property module, and the material editor appears. 

1. In the Edit Material dialog box, name the material steel. Notice the various options 
available in this dialog box.
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2. From the material editor’s menu bar, select MechanicalElasticityElastic.

Abaqus/CAE displays the Elastic data form.

3. Enter a value of 200.E3 for Young’s modulus and a value of 0.3 for Poisson’s ratio in the 
respective fields. Use [Tab] to move between cells, or use the mouse to select a cell for 
data entry.

4. Click OK to exit the material editor.

Defining and assigning section properties
Next, you will create a homogeneous solid section and assign it to the beam. The section will 
refer to the material steel that you just created.

To define the homogeneous solid section:
1. In the Model Tree, double-click Sections to create a new section in the model Model-1.

The Create Section dialog box appears.

2. In the Create Section dialog box:

a. Name the section solid_section.

a. Accept the default category Solid and the default type Homogeneous.

b. Click Continue.
The solid section editor appears.

3. In the Edit Section dialog box:

b. Accept the default selection of steel for the Material associated with the section.

c. Accept the default value of 1 for Plane stress/strain thickness.
Note: For three-dimensional solid geometry, this value is not used. It is only 
relevant for two-dimensional geometry.

d. Click OK.

To assign the section definition to the cantilever beam:
1. In the Model Tree, expand the branch for the part Part-1 (click the “+” symbol to expand 

the Parts container and then click the “+” symbol next to the part Part-1).
2. Double-click Section Assignments to assign a section to the part Part-1.

Abaqus/CAE displays prompts in the prompt area to guide you through the procedure.

3. Drag pick or shift click to select all cells in the entire part as the region to which the 
section will be assigned.

4. Click mouse button 2 in the viewport or click Done in the prompt area to accept the 
selected geometry.
The section assignment editor appears.

5. In the Edit Section Assignment dialog box, accept the default selection of 
solid_section as the section definition, and click OK.

Abaqus/CAE colors the lug green to indicate that the section has been assigned. 
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Assembling the model
The assembly for this analysis consists of a single instance of the part Part-1.

To assemble the model:

1. In the Model Tree, expand the branch for the Assembly of the model Model-1 and 
double-click Instances to create a new part instance.
Abaqus/CAE switches to the Assembly module, and the Create Instance dialog box 
appears.

2. In the Create Instance dialog box, select Part-1, accept the Instance type by default 
and click OK.
Abaqus/CAE displays the new part instance in the viewport.

Configuring the analysis
In this simulation we are interested in the static response of the lug to a pressure load applied 
over one half of the hole surface. This is a single event, so only a single analysis step is needed
for the simulation. Consequently, this model will consist of two steps:

 An initial step, in which you will apply a boundary condition that constrains one end of 
the lug. 

 A general, static analysis step, in which you will apply a pressure load to the bottom face
of the hole.

Abaqus/CAE generates the initial step automatically, but you must create the analysis step 
yourself. 

To create a general, static analysis step:

1. In the Model Tree, double-click Steps to create a new step in the model Model-1. 
Abaqus/CAE switches to the Step module, and the Create Step dialog box appears.

2. In the Create Step dialog box:
a. Name the step Step-1.
b. From the list of available general procedures in the Create Step dialog box, 

select Static, General if it is not already selected.
c. Click Continue.

The step editor appears.
3. In the Edit Step dialog box:

a. In the Description field of the Basic tabbed page, enter Load the lug.
b. Click the Incrementation tab, and accept the value of 1 that appears in the 

Initial text field.
c. Click the Other tab to see its contents; you can accept the default values 

provided for the step.
d. Click OK to create the step and to exit the step editor.
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Applying a boundary condition and a load to the model
Next, you will define the boundary condition and loading that will be active during Step-1.

To apply boundary conditions to one end of the lug:

1. In the Model Tree, double-click BCs to create a new boundary condition in the model 
Model-1. 
Abaqus/CAE switches to the Load module, and the Create Boundary Condition dialog 
box appears.

2. In the Create Boundary Condition dialog box:
a. Name the boundary condition Fixed.

e. Select Initial as the step in which the boundary condition will be 
activated.
f. In the Category list, accept the default category selection Mechanical.
g. In the Types for Selected Step list, select 
Symmetry/Antisymmetry/Encastre as the type.
h. Click Continue.
Abaqus/CAE displays prompts in the prompt area to guide you through the 
procedure. The face at the flat end of the lug will be fixed.

3. Select both faces of the rectangular end of the lug and create a set named fixed-end in 
the dialogue box. Click mouse button 2 in the viewport or click Done in the prompt area 
to accept the selected geometry.
The Edit Boundary Condition dialog box appears. When you are defining a boundary 
condition in the initial step, all six degrees of freedom are unconstrained by default.

4. In the Edit Boundary Condition dialog box:
a. Toggle on ENCASTRE to fully fix the end of the lug. Abaqus will simply ignore the

rotational degrees of freedom BCs since they do not exist for solid continuum 
elements.
i. Click OK to create the boundary condition definition and to exit the editor.
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Abaqus/CAE displays arrows at each corner and midpoint on the selected face to 
indicate the constrained degrees of freedom.

To apply a load to the bottom face of the hole:

1. In the Model Tree, double-click Loads to create a new load in the model Model-1.
The Create Load dialog box appears.

2. In the Create Load dialog box:
a. Name the load Pressure.

j. Select Step-1 as the step in which the load will be applied.
k. In the Category list, accept the default category selection Mechanical.
l. In the Types for Selected Step list, select Pressure.
m. Click Continue.

Abaqus/CAE displays prompts in the prompt area to guide you through the procedure.
3. In the viewport, select the two inside lower faces of the hole in the lug as the surface to 

which the load will be applied.

4. Name the pressure surface press and click mouse button 2 in the viewport or click Done
in the prompt area to indicate that you have finished selecting regions.

5. In the Edit Load dialog box:
c. Enter a magnitude of 50 for the load.

n. Accept the default Amplitude selection (Ramp) and the default 
Distribution (Uniform).
o. Click OK to create the load definition and to exit the editor.

Abaqus/CAE displays downward–pointing arrows on the lower hole faces to indicate the 
load application.

Save the Abaqus/CAE database.
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Meshing the model
You use the Mesh module to generate the finite element mesh. You can choose the meshing 
technique that Abaqus/CAE will use to create the mesh, the element shape, and the element 
type. Abaqus/CAE uses a number of different meshing techniques. The default meshing 
technique assigned to the model is indicated by the color of the model when you enter the Mesh
module; if Abaqus/CAE displays the model in orange, it cannot be meshed without assistance 
from the user.

To assign the mesh controls:

1. In the Model Tree, double-click Mesh in the branch for the part Part-1. 
Abaqus/CAE switches to the Mesh module and displays the part Part-1.

2. From the main menu bar, select MeshControls.

3. From the prompt area select the Regions on which you wish to assign mesh controls.
4. In the Mesh Controls dialog box, accept Hex as the default Element Shape selection.
5. Accept Structured as the default Technique selection.
6. Click OK to assign the mesh controls and to close the dialog box.

To assign an Abaqus element type:
1. From the main menu bar, select MeshElement Type.

2. In the Element Type dialog box, accept the following default selections that control the 
elements that are available for selection:

 Standard is the default Element Library selection.

 3D Stress is the default Family of elements.

Change the Geometric Order from Linear to Quadratic

3. In the middle portion of the dialog box, examine the element shape options. A brief 
description of the default element selection is available at the bottom of each tabbed 
page.

4. In the Hex tabbed page, accept the default Reduced integration.
A description of the element type C3D20R appears at the bottom of the dialog box. 
Abaqus/CAE will now use C3D20R elements when we apply the mesh.

5. Click OK to assign the element type and to close the dialog box.

To mesh the model:
6. From the main menu bar, select SeedPart to seed the part.

The Global Seeds dialog box appears. The default global element size is based on the 
size of the part.

7. In the Global Seeds dialog box, enter an approximate global size of 2 and click OK. 
Abaqus/CAE applies the seeds to the part.

8. From the main menu bar, select MeshPart to mesh the part.

9. Click Yes in the prompt area or click mouse button 2 in the viewport to confirm that you 
want to mesh the part instance.

10.Abaqus/CAE meshes the part instance and displays the resulting mesh.
Save the Abaqus/CAE database.
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Topology Optimization
Now you will perform a topology optimization of the lug. The aim will be to reduce the weight 
(volume) of the part whilst maximizing the stiffness, taking into account manufacturing 
limitations.

Create the Optimization Task
1. In the model tree double click Optimization Tasks. Abaqus/CAE will automatically 

switch to the Optimization Module and open the Create Optimization Task window. 
Accept the default Topology optimization and click continue.

2. Clear the Create Set box and click done to select the whole part as the optimization 
region.

3. On the Advanced tab select Condition-based optimization.

4. Accept all other defaults and click OK to complete the task.

Create the Design Responses
5. In the model tree open the Optimization Tasks, then Task-1 by clicking on the + button.

Then double click Design Responses. Abaqus/CAE will automatically open the Create 
Design Response window. Name the response DRESP_Strain_Energy. Accept the 
default Single Term and click continue.

6. Select Whole Model as the design response region type.

7. Select Strain energy as the variable, accept all other defaults and click OK.

8. Repeat these operations to add a second design response named DRESP_Volume 
choosing volume as the variable.

Create the Objective Function
9. In the model tree open the Optimization Tasks, then Task-1 by clicking on the + button.

Then double click Objective Functions. Abaqus/CAE will automatically open the Create
Objective Function window. Name the response obj_max_stiffness and click 
continue.

10.Accept the Minimize design response values target.
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11.Click in the Name box and select the design response DRESP_Strain_Energy.

12.Accept all other defaults and click OK.

Create the optimization Constraints
13. In the model tree open the Optimization Tasks, then Task-1 by clicking on the + button.

Then double click Constraints. Abaqus/CAE will automatically open the Create 
Constraint window. Name the constraint constraint_volume and click continue.

14.Use the dropdown to populate the design response name box with DRESP_Volume.

15.Change the constraint response to A fraction of the initial value and set this to 0.3.

16.Click OK to complete the constraint.

Create the Geometric Restrictions

17.First you need to create an element set to apply the restriction to. Select  from the 

views toolbar and then remove the perspective by clicking .

18.From the main menu select Tools > Set > Create. Name the set frozen_elems and set 
the type to Element. Click continue, Abaqus/CAE will automatically populate the screen
with elements. Use shift click to select all perimeter elements, 4 deep at the fixed end, to
add to the set. Ctrl click will remove elements selected in error. Note you can also try 
select by topology rather than Individually.

19. In the model tree open the Optimization Tasks, then Task-1 by clicking on the + button.
Then double click Geometric Restrictions. Abaqus/CAE will automatically open the 
Create Geometric Restriction window. Select Type Frozen area and click continue.

20.Select the Sets button in the bottom right of the graphics pane, then select 
frozen_elems and continue.

21.Click OK to complete the first restriction.

22.Create a second Geometric Restriction of Type Demold control (Topology), select 
done to include the whole model. Accept the default Demolding with a central plane 

and for the Pull Direction select the vector definition and use the  button to define a 
vector with start point (0,0,0) and end point (0,0,1). Click OK to complete the Geometric 
Restriction.
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Save the Abaqus/CAE database

Creating and submitting an analysis job
The definition of the model Model-1 is now complete. Next, you will create and submit an 
analysis job to analyze the model, and then an Optimization job to perform the optimization.

To create and submit an analysis job:
1. In the Model Tree, double-click Jobs to create a new analysis job.

Abaqus/CAE switches to the Job module, and the Create Job dialog box appears.

2. In the Create Job dialog box, name the job lug-analysis and select the model Model-1.
Click Continue.
The job editor appears.

3. In the Description field of the Edit Job dialog box, enter Workshop 2.
4. Click the tabs to see the contents of each folder of the job editor and to review the 

default settings. Click OK to accept the default job settings.
5. From the menu toolbar select Job > Manager.

The menu for the job manager appears.
6. From the job manager, select the job lug-analysis then select Submit.

7. As the job runs the status will be shown in the job manager window. Select Monitor to 
follow the status of the job as it runs. Click on each of the tabs to see what is reported 
during/after analysis.

Viewing the analysis results
You are now ready to view the results of the analysis in the Visualization module.

1. In the Model Tree, click mouse button 3 on the job lug-analysis and select Results from
the menu that appears. Abaqus/CAE switches to the Visualization module, opens the 
output database created by the job (lug-analysis.odb), and displays the undeformed 
shape of the model.

2. Click on the Plot Contours on Deformed Shape button  to see a contour plot of the 
field variables.

3. Select Options > Common from the main menu to change the style of the plot and/or 
the deformation scale factor of the plot.

Creating and submitting an Optimization job
Next, you will create and submit an Optimization job to perform the optimization.

To create and submit an analysis job:
1. In the Model Tree, double-click Optimization Processes to create a new 

optimization job.
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Abaqus/CAE switches to the Job module, and the Edit Optimization Process 
dialog box appears.

2. In the dialog box, name the job optimize_lug_mm and select the model Model-1 
and the Task Task-1.

3. In the Description field of the Edit Job dialog box, enter Workshop 2 – topological 
optimization.

4. Click the Parallelization tab to use multiple processors and set the number to 4. 
Click OK to complete the process definition.

5. From the menu toolbar select Optimization > Submit > optimize_lug_mm.
The optimization process begins.

6. From the main menu select Optimization > Monitor > optimize_lug_mm. to 
review progress with the optimization process. As the job runs the status will be 
shown in the monitor window.

Viewing the optimization results
You are now ready to view the results of the optimization in the Visualization module.

1. In the Model Tree, click mouse button 3 on the optimization process optimize_lug_mm 
and select Combine from the menu that appears to generate a unique results file (.odb).
Abaqus/CAE opens the Combine Optimization Results window. Note the location of 
the results directory and note and accept all other default settings. Click submit to 
combine the results of all the individual optimization analyses. Then Close the window.

2. In the Model Tree, click mouse button 3 on the optimization process optimize_lug_mm 
and select Results from the menu that appears. Abaqus/CAE switches to the 
Visualization module and displays the optimized topology of the lug
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These raw results from the topology optimization process are generally not useable – if you 
contour stresses you will notice a marked increase in von Mises stress over the original Part.
So you will extract a smoothed surface from this optimization to work with in a new Abaqus/CAE
database.

1. Switch back to the Optimization module and expand the Optimization Processes on 
the model tree. Click mouse button 3 on the Optimization Process optimize_lug_mm 
and select Extract.

2. Abaqus/CAE displays the Extract Surface Mesh Options dialogue box. Name the 
output optimize_lug_mm_surface; select Abaqus input file for format and use the 
output from the last design cycle (15). Change the Iso value (0-1) to 0.1. Then click 
Extract to generate the input deck (optimize_lug_mm_surface.inp) of the surface.
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